// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.*? )?(dog|car|house|work|cat) .*?(dog|car|house|work|cat) .*?(dog|car|house|work|cat)( .*)?$").unwrap();
let string = "I always let my cat and dog at the animal nursery when I go to work by car
The dog jumped over the house to get to work
The dog and cat are friends
The dog jumped over the houses to get to work
This sentence has four consecutive words to match cat dog house car";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}