package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^([a-z]{2})(\-([a-z]{2}))?$`)
var str = `en-US
ar-dz
zn-CN
tr
ru`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}