$re = '/^([a-z]{2})(\-([a-z]{2}))?$/mi';
$str = 'en-US
ar-dz
zn-CN
tr
ru';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);