package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+[-+]\d+=`)
var str = `12+13=
34-111122=
212+1232-12=
12121+321-121+121=`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}