$re = '/^\d+[-+]\d+=/m';
$str = '12+13=
34-111122=
212+1232-12=
12121+321-121+121=';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);