# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d{4}\w{4}\.\d{1,3})(?=\d{4})/\1,/g;t' <<< " 1710ABCD.131711ABCD.431711ABCD.41711ABCD.4041711ABCD.25"