#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\d{4}\w{4}\.\d{1,3})(?=\d{4})"
Local $sString = " 1710ABCD.131711ABCD.431711ABCD.41711ABCD.4041711ABCD.25"
Local $sSubst = "\1,"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)