const regex = /\b(?:e\.g\.|i\.e\.)(*SKIP)(*F)|(?:\b|\h+)?\pP+(?:\b|\h+)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:e\\.g\\.|i\\.e\\.)(*SKIP)(*F)|(?:\\b|\\h+)?\\pP+(?:\\b|\\h+)?', 'g')
const str = `Blabla, i.e. e.g. blabla...`;
const subst = ` \0`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);