re = /\b(?:e\.g\.|i\.e\.)(*SKIP)(*F)|(?:\b|\h+)?\pP+(?:\b|\h+)?/
str = 'Blabla, i.e. e.g. blabla...'
subst = ' \\0'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result