using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a\s+ # Look for '<a' followed by whitespace
([^>]+\s+)? # Look for anything else that isn't 'href='
# such as 'class=' or 'id='
href\s*=\s* # locate the 'href=' with any whitespace around the '=' character
(
'([^']*)' # Look for '...'
| # ...or...
""([^""]*) # Look for ""...""
| # ...or...
([^\s>]+) # Look anything NOT '>' or spaces
)
[^>]*> # Match anything else up to the closing '>'
";
string input = @"<!DOCTYPE html>
<html>
<head>
<title>Hyperlinks</title>
<link href=""theme.css"" rel=""stylesheet"" />
</head>
<body>
<ul><li><a href=""/"" id=""home"">Home</a></li><li><a
class=""selected"" href=/courses>Courses</a>
</li><li><a href =
'/forum' >Forum</a></li><li><a class=""href""
onclick=""go()"" href= ""#"">Forum</a></li>
<li><a id=""js"" href =
""javascript:alert('hi yo')"" class=""new"">click</a></li>
<li><a id='nakov' href =
http://www.nakov.com class='new'>nak</a></li></ul>
<a href=""#empty""></a>
<a id=""href"">href='fake'<img src='http://abv.bg/i.gif'
alt='abv'/></a><a href=""#""><a href='hello'></a>
<!-- This code is commented:
<a href=""#commented"">commentex hyperlink</a> -->
</body>
";
RegexOptions options = RegexOptions.IgnorePatternWhitespace | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}