import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a\\s+ # Look for '<a' followed by whitespace\n"
+ "([^>]+\\s+)? # Look for anything else that isn't 'href='\n"
+ " # such as 'class=' or 'id='\n"
+ "href\\s*=\\s* # locate the 'href=' with any whitespace around the '=' character\n"
+ "(\n"
+ " '([^']*)' # Look for '...'\n"
+ "| # ...or...\n"
+ " \"([^\"]*) # Look for \"...\"\n"
+ "| # ...or...\n"
+ " ([^\\s>]+) # Look anything NOT '>' or spaces\n"
+ ")\n"
+ "[^>]*> # Match anything else up to the closing '>'\n";
final String string = "<!DOCTYPE html>\n"
+ "<html>\n"
+ "<head>\n"
+ " <title>Hyperlinks</title>\n"
+ " <link href=\"theme.css\" rel=\"stylesheet\" />\n"
+ "</head>\n"
+ "<body>\n"
+ "<ul><li><a href=\"/\" id=\"home\">Home</a></li><li><a\n"
+ " class=\"selected\" href=/courses>Courses</a>\n"
+ "</li><li><a href = \n"
+ "'/forum' >Forum</a></li><li><a class=\"href\"\n"
+ "onclick=\"go()\" href= \"#\">Forum</a></li>\n"
+ "<li><a id=\"js\" href =\n"
+ "\"javascript:alert('hi yo')\" class=\"new\">click</a></li>\n"
+ "<li><a id='nakov' href =\n"
+ "http://www.nakov.com class='new'>nak</a></li></ul>\n"
+ "<a href=\"#empty\"></a>\n"
+ "<a id=\"href\">href='fake'<img src='http://abv.bg/i.gif' \n"
+ "alt='abv'/></a><a href=\"#\"><a href='hello'></a>\n"
+ "<!-- This code is commented:\n"
+ " <a href=\"#commented\">commentex hyperlink</a> -->\n"
+ "</body>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}