const regex = /[\x{0591}-\x{05AF}\x{05BE}\x{05C0}\x{05C3}]/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\x{0591}-\\x{05AF}\\x{05BE}\\x{05C0}\\x{05C3}]', 'gu')
const str = `בְּרֵאשִׁ֖ית בָּרָ֣א אֱלֹהִ֑ים אֵ֥ת הַשָּׁמַ֖יִם וְאֵ֥ת הָאָֽרֶץ`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);