re = /[\x{0591}-\x{05AF}\x{05BE}\x{05C0}\x{05C3}]/
str = 'בְּרֵאשִׁ֖ית בָּרָ֣א אֱלֹהִ֑ים אֵ֥ת הַשָּׁמַ֖יִם וְאֵ֥ת הָאָֽרֶץ'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result