import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![-\\w])crudefn\\.segment-id(?![-\\w])";
final String string = "where x-crudefn.segment-id[5] =crudefn.segment-id[v-idx]\n"
+ "where x-crudefn.segment-id[5] =crudefn.segment-id[v-idx]\n"
+ "where x-crudefn.segment-id[5] = a + crudefn.segment-id[v-idx]";
final String subst = "new-value";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}