$re = '/(?<![-\w])crudefn\.segment-id(?![-\w])/';
$str = 'where x-crudefn.segment-id[5] =crudefn.segment-id[v-idx]
where x-crudefn.segment-id[5] =crudefn.segment-id[v-idx]
where x-crudefn.segment-id[5] = a + crudefn.segment-id[v-idx]';
$subst = "new-value";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;