using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<table.*>\S*?\n*?</table>";
string input = @"<table>xccsd
<tr><td>
<table>
<tr><td>foo</td></tr>
</table>
</td></tr>
</table>
bubblegum
<table class=""ups"" collapse-heading>
<tr><td>
<table>
<tr><td>foo</td></tr>
</table>
<table><tr><td>foo</td></tr></table>
<table test class=""some""><tr><td>foo</td></tr></table>
</td></tr>
</table>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}