// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<table.*>\S*?\n*?</table>").unwrap();
let string = "<table>xccsd
<tr><td>
<table>
<tr><td>foo</td></tr>
</table>
</td></tr>
</table>
bubblegum
<table class=\"ups\" collapse-heading>
<tr><td>
<table>
<tr><td>foo</td></tr>
</table>
<table><tr><td>foo</td></tr></table>
<table test class=\"some\"><tr><td>foo</td></tr></table>
</td></tr>
</table>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}