import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<key>[a-zA-Z0-9])=(?P<value_with_delimiters>(?P<delimiter>\\\"*)(?P<value_without_delimiters>.+?)(\\3))(?: +|$)";
final String string = "a=\"hello world\" b=\"\"very cool\"\" c=8.8.8.8\n"
+ "d=\"\"hello\"world\"\n"
+ "e=\"\"\"triple quoted also works\"\"\"\n"
+ "f=\"\"\"\"and \"\"\" any \" quotes \"\" that are less than the surrounding pairs\"\"\"\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}