use strict;
my $str = 'a="hello world" b=""very cool"" c=8.8.8.8
d=""hello"world"
e="""triple quoted also works"""
f=""""and """ any " quotes "" that are less than the surrounding pairs""""';
my $regex = qr/(?P<key>[a-zA-Z0-9])=(?P<value_with_delimiters>(?P<delimiter>\"*)(?P<value_without_delimiters>.+?)(\3))(?: +|$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}