re = /(?:[^\\|]|\\[\s\S])+/m
str = 'fielda|field b |field\\|with\\|pipe\\|inside'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end