import re
regex = re.compile(r"\b(?:(?:EN|DE|FR)\s+(?:ISO|DIN)|(?:ISO|DIN)\s+(?:EN|DE|FR))\s+\d+[-:]\d+", flags=re.MULTILINE)
test_str = "FR ISO 23213:2020 or DIN EN 2323-2"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")