import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?<!-)(?<role_name>[a-z0-9]+(?:-[a-z0-9]+)*?)(?:-([a-f0-9]{10}))?-([a-z0-9]+)\\b(?!-)";
final String string = "events-worker-7c9b7bdc55-f7sgc\n"
+ "notification-585f6b94b8-t4jjc\n"
+ "report-generator-749ccf648d-gd9j7\n"
+ "static-content-8445d7f556-wbxvp\n"
+ "init-database-fm44h\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}