use strict;
my $str = ' abcd_test.py
test.py
xyz_test.js
test.js
asdsad.sad
sad asd
word dkkdk mfkmkf
lkdskdlk word2
ghhg hjkh
';
my $regex = qr/(?i)(?s)(?!.*?word2)^.*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}