$re = '/(?i)(?s)(?!.*?word2)^.*$/m';
$str = ' abcd_test.py
test.py
xyz_test.js
test.js
asdsad.sad
sad asd
word dkkdk mfkmkf
lkdskdlk word2
ghhg hjkh
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);