package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?is)<a[^>]*>.*?[a-z].*?</a>`)
var str = `<a href="link">бпцй</a><a href="link">бпцй</a>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}