$re = '%<a[^>]*>.*?[a-z].*?</a>%is';
$str = '<a href="link">бпцй</a><a href="link">бпцй</a>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);