re = /.*?(\s*#\w+)|.+/m
str = 'This is a #text, which is #full of #hashtags.
Well, this is not #easy to
#extract #them.
I think I #start to #% lose: #hope.'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result