import Foundation
let pattern = ##".*?(\s*#\w+)|.+"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
This is a #text, which is #full of #hashtags.
Well, this is not #easy to
#extract #them.
I think I #start to #% lose: #hope.
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)