$re = '/(?:(^[^ \t\*\n\|]+)|((?<=^\|)\s+[^ \t\*\n\|]+)).*(?:\s{2}|\t|$|\s+(?=\|))/m';
$str = 'qas defrefrfgregregoivn ev etrg
| 1|2|3
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);