re = /(?:(^[^ \t\*\n\|]+)|((?<=^\|)\s+[^ \t\*\n\|]+)).*(?:\s{2}|\t|$|\s+(?=\|))/m
str = 'qas defrefrfgregregoivn ev etrg
| 1|2|3
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end