using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"images\/(?<image>.+?)(\/|$)(?<width>\d+)(\/|$)(?<height>\d+)(\/|$)";
string substitution = @"";
string input = @"/images/my.jpg
/images/my.jpg/200
/images/my.jpg/200/
/images/my.jpg/200/400
/images/my.jpg/200/400/";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}