package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)images\/(?<image>.+?)(\/|$)(?<width>\d+)(\/|$)(?<height>\d+)(\/|$)`)
var str = `/images/my.jpg
/images/my.jpg/200
/images/my.jpg/200/
/images/my.jpg/200/400
/images/my.jpg/200/400/`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}