use strict;
my $str = 'https://dsc.gg/typical-utility
https://dsc.gg/contentcafécontentcafé
https://discord.gg/AQW3Uzu
https://dsc.lol/the-imagining
https://discord.gg/AQU3Uzu
https://discord.io/suppt4x
https://dsc.gg/c3media
https://dsc.gg/typical-support
https://dsc.gg/yungsmp
https://dsc.lol/the-imagining
https://www.ps3cfw.com/cool.php?item=30424465';
my $regex = qr/(https|http)://(dsc\.gg|discord\.gg|discord\.io|dsc\.lol)/?[\S]+/?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}