import re
regex = re.compile(r"(.*[a-zA-Z].*[@]\w*\.\w*)", flags=re.MULTILINE)
test_str = ("\n"
"123.123\n"
"123_123\n"
"123@123.123\n"
"123@123.com\n"
"123@abc.com\n"
"123mbc@abc.com\n"
"123mbc@123abc.com\n"
"123mbc@123abc.123com\n"
"123mbc123@cc123abc.c123com\n"
"john-can@g.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")