re = /(.*[a-zA-Z].*[@]\w*\.\w*)/m
str = '
123.123
123_123
123@123.123
123@123.com
123@abc.com
123mbc@abc.com
123mbc@123abc.com
123mbc@123abc.123com
123mbc123@cc123abc.c123com
john-can@g.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end