const regex = /^[a-zßüÜöÖäÄ_][-\wßüÜöÖäÄ ]*$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zßüÜöÖäÄ_][-\\wßüÜöÖäÄ ]*$', 'i')
const str = `Finanzmarktstabilisierungsfonds-Verordnung findet jedoch vorbehaltlich der Zahlung der Ausgleichsbeträge nach den`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}