using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<[^>]*>|[^<]+";
string input = @"aaa
<bbb>
aaa<bbb>
<bbb>aaa
aaa<bbb><ccc>
<bbb>aaa<ccc>
<bbb><ccc>aaa";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}