package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<[^>]*>|[^<]+`)
var str = `aaa
<bbb>
aaa<bbb>
<bbb>aaa
aaa<bbb><ccc>
<bbb>aaa<ccc>
<bbb><ccc>aaa`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}