#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\b(?:\w+)?\d+(?:\w+)?(?:[\-\/])?(?:\w+)?(?:\d+)?\b)"
Local $sString = "Park Avenue number 100" & @CRLF & _
"Baker Street number 100" & @CRLF & _
"Baker Street 100" & @CRLF & _
"The bakery shop is located on 109-111 Wharfside Street" & @CRLF & _
"My mother's house is on 40-42 Parkway" & @CRLF & _
"My schoolmate lives in 25b-26 Sun Street" & @CRLF & _
"The apartment is located on R2-R3 City Quay" & @CRLF & _
"I live in 43a Garden Walk" & @CRLF & _
"I live in 6/7 Marine Road" & @CRLF & _
"I live in 10-12 Acacia Ave" & @CRLF & _
"I live in 4513 3RD STREET CIRCLE WEST" & @CRLF & _
"I live in 1/2 Fifth Avenue" & @CRLF & _
"number C3-H4 sawojajar Malang"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")