# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\b(?:\w+)?\d+(?:\w+)?(?:[\-\/])?(?:\w+)?(?:\d+)?\b)"
test_str = ("Park Avenue number 100\n"
"Baker Street number 100\n"
"Baker Street 100\n"
"The bakery shop is located on 109-111 Wharfside Street\n"
"My mother's house is on 40-42 Parkway\n"
"My schoolmate lives in 25b-26 Sun Street\n"
"The apartment is located on R2-R3 City Quay\n"
"I live in 43a Garden Walk\n"
"I live in 6/7 Marine Road\n"
"I live in 10-12 Acacia Ave\n"
"I live in 4513 3RD STREET CIRCLE WEST\n"
"I live in 1/2 Fifth Avenue\n"
"number C3-H4 sawojajar Malang")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.