using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{\{(?:[^{}]*|(?R))+\}\}";
string input = @"{{detect this {{and this as well}} text}} but text does not ends here so it should {{not detect this}}.";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}