$re = '~\{\{(?:[^{}]*|(?R))+\}\}~';
$str = '{{detect this {{and this as well}} text}} but text does not ends here so it should {{not detect this}}.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);