const regex = /(?:[A-Z{1}a-z\d]*\@{1}[A-Za-z\d]*\.{1}[A-Za-z\d]+)/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:[A-Z{1}a-z\\d]*\\@{1}[A-Za-z\\d]*\\.{1}[A-Za-z\\d]+)', 'i')
const str = `chanpreetsingh@sap.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}