re = /(?:[A-Z{1}a-z\d]*\@{1}[A-Za-z\d]*\.{1}[A-Za-z\d]+)/i
str = 'chanpreetsingh@sap.com'
# Print the match result
str.match(re) do |match|
puts match.to_s
end