package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<\?\s*((?:.*\/\*[\s\S]+\*\/.*)|(?:[\s\S]+?))\s*\?>`)
var str = `<input type=text value="<? print(code); ?>"><? /* */ ?>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}