re = /<\?\s*((?:.*\/\*[\s\S]+\*\/.*)|(?:[\s\S]+?))\s*\?>/
str = '<input type=text value="<? print(code); ?>"><? /* */ ?>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end