using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<=[MDE]r\.|Mrs\.|Ms\.)[a-zA-Z]+$";
string input = @"Mr.Jhon";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}