const regex = /^(?<=[MDE]r\.|Mrs\.|Ms\.)[a-zA-Z]+$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<=[MDE]r\\.|Mrs\\.|Ms\\.)[a-zA-Z]+$', '')
const str = `Mr.Jhon`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}