using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"is(?=.*<\/pre>)";
string input = @"is <pre>is Is this hi all there is </pre> is";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}