$re = '/is(?=.*<\/pre>)/';
$str = 'is <pre>is Is this hi all there is </pre> is';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);